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User Manual For Beginner : How To Use Joomla 3.0 
 
1.0   How to Access Joomla Login Screen 

 
a) On this page, you will find a login screen, where you need to enter the username and 

password you've chosen during the Joomla 3 installation process. 
 

 
 
 

2.0  How to Change Joomla Admin Language 
 

a) To begin, first login to your Joomla admin area. Next, go to Extensions -> Language 
Manager to open the list of installed languages for your site. 

 

 
 
b) On this page you will see all available languages. On a default installation, you should 

only see English. To add more translations, press the Install Language button in the 
top, left part of the page.  
 

 
 

https://www.siteground.com/tutorials/joomla/login.htm


c) To proceed, select a language (the search function is really handy here) and press 
the Install button. For the purpose of this tutorial, we will change the language for 
the admin area to Bulgarian.  

 

 
 
d) In few seconds, the new language pack will be installed into your application. 
 

 
 
e) That's it, your Joomla admin panel will now work in the newly installed and selected 

language. 
 

 
 
 

You can change the language for individual users from the Users menu -> User 
Manager -> Basic Settings. 

 
  



3.0 How to Create a Website with Joomla 
 

3.1 How to create Joomla articles 
 
a) Klik > Article Manager > Add New Article 

 

 
 

 
b) When you click on Add New Article, you will see a WYSIWYG editor that you can 

use to write and format your new article text, add images & links to it, and more. 
 

c) To make your article visible on your website for all visitors, you need to put it 
on Published status and Public Access. 

 
 

 
 

3.2 How to link articles in the Joomla  
 
a) To do this you need to use the Main menu manager. 

  



b) Klik > Menus > Main Menu > Add New Main Menu 
 

 
 

c) After you have indicated that you want to create a new menu item, you will have to 
select the type of the menu item. 
 

 
 

d) Since we will be linking content created through the Article manager we should 
click on the Articles link 
in the list. 
 

e) If you want the new menu to simply open the article you have just created simply 
press the Single Article option. 
 

 
 

f) Once you choose this option, a box for selecting which article exactly you wish to 
link to will appear. 
 

g) That's it, you can now open your website and see your newly created menu item that 
links to your new Joomla article.  



 

 
 
 

4.0  How to Create and Manage Categories in Joomla 
 

4.1 How to manage Article categories 
 
a) To add a new category, go to Content -> Category Manager -> Add New Category. 

 

 
 
b) Categories don't have a lot of properties. If you plan to have many categories, you 

can write a brief description of each one of them in order to avoid mistakes when 
you add articles to them. 
 

c) However, adding description is not mandatory, so you can simply add Title for your 
category and press the green Save button. 
 

 



 
d) That's it. Now, when you add new articles to your website, you can choose them to 

belong to the newly created category. 
 

 
 
4.2 How to manage Component categories 
 
a) You can organize the feeds you display on your website in different categories 

 
b) They work exactly the same as the ones for your articles, but they are located in the 

individual component's menu. 
 

 
 

c) The only difference between article and component categories is that when you 
choose the categories menu for the particular component, you're redirected directly 
to the categories manager for that component. 
 

d) Here, you need to press the green New button in order to add a category. 
 

 



e) This page is exactly the same as the one used for article categories - add Category 
Title, Description(optional), and hit the save button. 
 

 
 

 

4.3 Listing Categories on a Joomla 
 
a) First, add a new item to the menu, as we previously did in our tutorial on 

linking articles in the Joomla menu with one minor difference - this time, you need to 
choose a different menu type. 
 

b) Go to Menus -> Main Menu(or other menu in your site) -> Add New Menu Item. 
 

 
 

c) Here, click on the Select button next to the Menu Item Type label to choose what 
kind of menu you want to add. 
 

 
 

  



d) For the purpose of this tutorial, we will add a menu item, that will display all the 
categories of articles we have previously added. To do so, expand the Articles 
section and press List All Categories. 
 

 
 

e) Finally, choose the title for your menu item and the Top level category you want to 
display. If you want to show all categories, select "Root". 
 

f) If you want to display only sub-categories of a particular category, you need to set it 
as a top level category. 
 

g) Finally, press the Save button in the top left part of the screen. 
 

 
 
h) That's it, once you click on the newly created menu item Categories Menu, you will 

see a list of all the article categories. Next to each category, you will see a number 
showing how many articles belong to that category. 
 

 
 



5.0 Joomla Featured Article 
 

5.1 Mark Joomla 3 articles Featured 
 
a) First, you need to mark some articles in your site as Featured 

 
b) To do this, go to Content -> Articles Manager. 

 
c) You will see a list of your articles. Note that there is a star next to each article. To 

mark an article as Featured, simply press the star next to it. It will turn yellow, 
indicating that you've marked this article as featured. 
 

 
 

 

5.2 Show Featured articles on a page linked in the Joomla menu 
 
a) If you want to manually choose the articles displayed on a page, the Featured 

Articles menu type in Joomla 3 is exactly what you need. 
 

b) To do this go to Menus -> Main Menu(default main menu) -> Add New Menu Item 
(you can do the same with existing menu items, for example the Home menu). 
 

 
 



c) Next, we should select the menu type by pressing the Select button next to the 
Menu Item Type label. 
 

 
 

d) A popup with the available menu types will appear. Expand the Articles section and 
select the Featured Articles option. 
 

 
 

e) Finally, press the Save button in the top left corner of this page. 
 

 
 

5.3 Customize the way articles are arranged on this page through the    
menu. 
 
By default Joomla 3 will show the full text of the latest featured article expanded on the 
top of the page, and the full text of the next 4 articles displayed in two columns. If you 
have more than 5 featured articles the rest will be listed as links on the bottom of the 
page, and pagination will be automatically created that leads to next pages featuring the 
full texts of the rest of the articles. 



 

 
 

a) You can change the way articles are displayed through the menu item’s Advanced 
Options tab (Menus -> Main Menu -> Menu Item -> Advanced Options Tab). 
 

b) In the first article that takes all of the width is called Leading Article. You can assign 
any number of articles you want, including 0, to be displayed this way. 
 

c) We do not want any article to be displayed in full width. Next you can choose how 
many intro articles will be shown after the leading ones on this page (we choose 6).  
 

d) You can also choose in how many Columns to show the Intro articles (we chose 3). 
Finally, choose how many of the remaining featured articles to be listed as Links at 
the bottom (we chose 3). 
 



 
  

e) You can play with these settings until you achieve a configuration you like. With the 
example settings we set the page will look like this. 
 

 
 

5.4 Manage how much of each article to be shown (Read More option) 

 
a) You can choose how much of each featured article to be shown on this page using 

the Read More feature in your articles manager. 
 



b) To do that open the article in the Article editor, click where you want to split the 
article and press the Read More button right below your WYSIWYG editor. A dotted 
red line will be displayed, separating your article intro from the rest of the article 
content. 
 

 
 
c) Once you do that, you will notice that Joomla has generated a Read More button 

right after the intro content you selected on the page where the article is featured 
together with the other ones. 
 

 
  



6.0  How to Create a Joomla Contact Us Page 
 

a) First, you need to create the actual content of your Contact Us page. 
 

b) Go to Components -> Contacts. On this page hit the green New button to create a 
new contacts page. 
 

 
 

c) Here you need to specify a unique name for that contact. For the purpose of this 
tutorial, we will make only one Contact Us page. We will not dig further into the 
different Contact us categories, since they basically use the same logic as Joomla 
articles.  
 

d) This is why we can safely leave the new contact page uncategorized. Finally, click on 
the Contact Details tab to proceed with the page creation. 
 

 
 

e) Now you need to enter your contact information. Make sure you enter a valid e-mail 
address, because it will be used by the contact form. Once you fill in all the 
information you want to share with your visitors, click on the Save button in the top 
left part of the page. 
 

 



 

6.1 Publish the newly created Contact 
 
a) Now, we need to enable this contact form. To do this, simply hit the red icon next to 

the Contact Form element in order to change its status from unpublished to publish. 
The icon should turn green and you can proceed with the next step of this tutorial. 
 

 
 
6.2 Link the Contact page in a Joomla menu 
 
a) We're almost done with the creation of the contact page. The last thing we need to 

do is to add a Contact Us link to the menu of our site. In our case, we will add it to the 
main menu. 
 

b) To do this, go to Menus -> Main Menu -> Add Menu Item. 
 

 
 
 

c) On this page there are few things you need to configure. First, click on the Select 
button next to the Menu Item Type field. 
 

 



d) A lightbox will appear asking you to choose the type of menu item you will be 
creating. Select Contacts -> Single Contact. 
 

 
 

e) Now you need to specify the exact Contact item you want to display in that menu. To 
do this, hit the Select button next to the Select Contact field. 
 

 
 

f) Once you do that, choose the form we've created through the default Joomla 3 
contact component (should be only one contact form that you can click on). 
 

 
  



g) Once you do that, select a title for that menu item. This is the actual text that will be 
shown on your site menu. Once you fill in that information, click on the Save button 
in the upper part of the page. 
 

 
 
With the example settings we set the page will look like this. 

 

 
  



7.0  Create a Joomla Drop-down Menu 
 

a) First, you need to access your Joomla 3 administrative area and go to Menus -> Main 
Menu -> Add New Menu Item. 
 

 
 

b) Now you need to select the menu item type. In this example we will show you how to 
make the drop-down menu link open a single Joomla article. To do this, click on the 
Select button next to the Menu Item Type label. 
 

 
 

c) A lightbox with the available menu items will appear. Select the Articles category 
and choose Single Article. 
 

 
  



d) Now you have to choose the actual article you want to link to. To do this, first click 
on the Select button next to the Select Article label. 
 

 
 

e) Once more a lightbox with all of your articles will appear. Choose the one you want 
to link to and click on its title. 
 

 
 

f) The next step is to enter a title for the menu item. To do this fill in the field next to 
the Menu Title label. In our tutorial we will create a sub-menu named Computers. 
 

 
 



g) Now the important part - find the Parent Item label and click on the drop-down 
menu next to it. Now select the parent menu for the new menu item we're creating.  
 

h) As we mentioned in the first paragraph, for the purpose of this tutorial we will 
choose an existing Products menu item as parent. 
 

 
 

i) Finally, click on the green Save button in the top left part of the page. 
 

 
 

That's it! You can now navigate to the front-end of your website and hover your mouse 
over the Products Menu. You will notice the newly created menu item appearing under 
it. 
 

 
 
  



8.0 How to Add Banners to Joomla 
 

a) To do this login to your Joomla admin area and go to Components -> Banners -> 
Banners. 
 

 
 

b) On this page, click on the green New button at the top left part of the page. 
 

 
 

c) First, choose a name for the banner. Name your banners with unique, meaningful 
names so you can easily organise them later. 
 

d) Next, select Custom from the Type drop-down. 
 

e) Finally, paste the banner code into the Custom Code field and press the Save & 
Close button. 
 

 
 



f) Now you need to publish a new module to display your newly embedded banner. To 
do this, go to Extensions -> Module Manager. 

 

 
 

g) Once more, press the green New button in order to add a new module to your site. 
 

 
 

h) Joomla 3 will provide you with a list of the available module types that you can 
choose from. Simply click on the banners type. 
 

 
  



i) On this page, you need to choose a title for the module and the position where it will 
be displayed. Note that the available positions and their names depend on the 
template you're currently using. Different templates have different places where you 
can add modules (in our case - banners). 
 

j) Once you chose title and position for the module, press the Save button at the top 
left part of the page. 
 

 
  

That's it! You can now browse to your website front-end and see your newly created 
banner. 
 

 
  



9.0  Joomla Positions 
 

a) Each Joomla template has positions in which you can publish different modules. 
 
b) When you install Joomla with the default template Protostar and some sample data, 

you will see 6 of them situated on your front end in the following way: 
 

 
 

c) In the default sample data there is no content in the left column (Left [position-8]) 
or the space above the first article (Top center [position-3]). If you publish any 
module in them, they will be visualized. The Debug [debug] is also not utilized by 
default. It's used mostly by developers to test their code and show debug 
information under the footer. 

 
9.1 How to publish a module in a chosen position? 
 
a) To illustrate the way you add modules to your site, we will add a search module to 

the default Joomla 3 template. To begin, go to Extensions -> Module Manager. 
 

 



 

b) Now, press the green New button in the top left part of the page to add a module. 
 

 
 

c) You will see a list of the available module types. Choose to add a Search module. 
 

d) On the next page, you will be asked to add some information for that module. Select 
a title for it - Search for example, and choose the module to be displayed in position-
0. Finally, click on the green Save button. 
 

 
  

9.2 How to change the position of a published module 
 

a) To change the position of a module, first login to your Joomla admin page and go to 
Extensions -> Module Manager. 



 
 

b) On this page you will see a list of your modules. For the purpose of this tutorial we 
will move the Latest Article module from the right column of the Joomla default 
template (position-7) to the left one (position-8).  
 

c) Find out the Latest Article module and click on its name. If you have trouble finding 
your module, use the search filter on top of the table which can be very useful if you 
have many modules. 

 

 
 

d) On this page, locate the Position drop down menu and click on it. You will see that a 
list of the available positions will appear. Select position-8. 
 

 
 
 
  



e) Finally, click on the green Save button on the top. 
 

 
 

f) That's it, you can now go to the front end of your website and see the Latest Article 
module showing in your left column. 
 

 
 

9.3 How to reorder modules published in the same position 
 

a) In the Joomla layout example above, we have two modules published in our right 
column - a search module and a "Latest Articles" module. 
 

b) To put the search module above the other one, first you need to go to 
Extensions -> Module Manager. 
 

 
 



c) Now, choose position-7 from the position drop-down filter in the left column to 
display only the modules, published into your right column. 
 

 
 

d) Next, you need to sort that table by its order. To do this click on the Ordering tab 
and select Sort table by: Ordering. 
 

 
 

e) Then, simply click on the three small dots in the first column of the table and then 
drag-and-drop the line for the Search module, above the Latest Article one. 
 

 
 



f) Once you do that, go to the front end of your Joomla site and you will notice that the 
Search module has moved above the Latest Articles one. 
 

 


